quarta-feira, 27 de março de 2013

Escrever um algoritmo que leia dois valores inteiro distintos e informe qual é o maior.

Escrever um algoritmo que leia dois valores inteiro distintos e informe qual é o maior.


algoritmo "Exemplo14"
// Função:
// Data : 
// Seção de Declarações
var
a, b: inteiro
inicio
// Seção de Comandos
escreval ("Informe o primeiro valor: ")
leia (a)
escreval ("Informe o segundo valor: ")
leia (b)
se a > b entao
escreval ("O valor ", a, " é maior que o valor ", b)
senao
escreval ("O valor ", b, " é maior que o valor ", a)
fimse
fimalgoritmo

6 comentários:

Anônimo disse...

agradecemos o empenho :)) mt obrigado do fundo do <3

Anônimo disse...

Está indicando erro em ''leia(a)''. Diz ''esperava encontrar ')'.'' Como conserto isso?

Anônimo disse...

MUITO OBRIGADO!

Viviane Vilanova disse...

Olá Jean,
Gostaria que me ajudasse na criação deste algoritmo:
Faça um algoritmo que leia três números inteiros e mostre o resto da divisão da soma dos números lidos por 4, 3 e 2.

Neiva dos Santos Lima disse...

Olá, seria possível responder esses algoritmos?

1. Faça um algoritmo que leia a marca, o modelo, e quantos quilômetros um carro percorre com um litro de gasolina e de álcool. Leia uma distância qualquer e calcule quanto o carro gastaria em reais para percorrer a distância com gasolina e com álcool. Assuma que o valor do litro do álcool é R$ 2,40 e da gasolina R$ 3,20, os valores do álcool e da gasolina deverão ser guardados em variáveis.
Resposta:

2. Faça um algoritmo que leia três números inteiros e mostre o resto da divisão da soma dos números lidos por 4, 3 e 2.
Resposta:

3. Faça um algoritmo que leia um valor inteiro em reais e informe quantas notas de 50, 20, 10 e 2 são necessárias para representar o valor, assuma que sempre será usada a maior quantidade possível de notas maiores.
Resposta:

4. Faça um algoritmo que calcule quanto se gasta para comprar salgados para uma festa. Sabe-se que um homem adulto come em média 5 salgados, uma mulher adulta come 4 e uma criança come 3. O programa deve ler a quantidade de homens, mulheres e crianças convidados e ao final informar a quantidade de salgados necessários e o custo. Cada salgado custa R$ 1,50. No programa o valor do salgado deve ser guardado em uma variável.
Resposta:

5. Faça um algoritmo que leia os valores de a,b e c e calcule os dois valores resultantes da fórmula de bhaskara.
Resposta:

Anônimo disse...

Faça um algoritmo que leia um valor inteiro em reais e informe quantas notas de 50, 20, 10 e 2 são necessárias para representar o valor, assuma que sempre será usada a maior quantidade possível de notas maiores.

Postar um comentário

 
;