segunda-feira, 25 de março de 2013

Escrever um algoritmo que leia o custo de fábrica de um carro e informe o custo ao consumidor do mesmo...

O custo ao consumidor de um carro novo é a soma do custo de fábrica com percentagem do distribuidor e dos impostos (aplicados, primeiro os impostos sobre o custo de fábrica, e depois a percentagem do distribuidor sobre o resultado). Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%. Escrever um algoritmo que leia o custo de fábrica de um carro e informe o custo ao consumidor do mesmo.


algoritmo "Exemplo12"
// Função : 
// Autor :
// Data : 
// Seção de Declarações
var
custo_fabrica, porc_distribuidor, impostos, cust_consumidor: real
inicio
// Seção de Comandos
escreval ("Informe o custo de fábrica do carro: ")
leia (custo_fabrica)
porc_distribuidor <- (custo_fabrica * 0.28) + custo_fabrica
cust_consumidor <- (porc_distribuidor * 0.45) + porc_distribuidor
escreval ("O valor do automóvel para o consumidor é: R$ ", cust_consumidor)
fimalgoritmo

17 comentários :

Juliana Santos disse...

Nossa, eu amei teu blog estou aprendendo a desenrolar os exercícios passados pelo meu prof. da facul!

MEira disse...
Este comentário foi removido pelo autor.
MEira disse...

Desculpe mas acredito que seu diagrama esteja errado, pois aplica-se primeiro os impostos sobre o custo de fábrica, e depois a percentagem do distribuidor sobre o resultado.
Exemplo:
impostos <- (custo_fabrica * 0.45) + custo_fabrica
cust_consumidor <- (impostos * 0.28) + custo_fabrica

Rafaela Almeida disse...
Este comentário foi removido pelo autor.
Anônimo disse...

Olá, teria como fazer esse algoritimo utilizando a linguagem C??

Anônimo disse...

Claro que teria como fazer com a linguagem C, tudo é possível. Desenvolva-o você mesmo(a), és capaz, acredito em, e Dilma no coração!

Anônimo disse...

Dilma corrupta do capeta, vá governar o inferno!

Igor Illys disse...

me ajudou bastante!!!

Renata disse...

Você colocou a variável impostos mas não a utilizou. E aquela parte do exercício "primeiro os impostos sobre o custo de fábrica, e depois a percentagem do distribuidor sobre o resultado"? Eu não entendidireito esse exercicio

hue disse...

Você batatou aí.

Anônimo disse...

MEira, também não acredito que seja assim o final... os 28% dos impostos do distribuidor são em cima do resultado do custo de fábrica + os 45% de impostos. Não se soma o custo de fábrica de novo.

impostos <- (custo_fabrica * 0.45) + custo_fabrica
cust_consumidor <- (impostos * 0.28) + impostos

Anônimo disse...

O unica que deu o resultado certo foi esse

Imposto <- (Custo_Fabricante * 0.45)
Porcentagem_Destribuidor <- (Custo_Fabricane * 0.28)
Custo_Consumidor <- Imposto + Porcentagem_Destribuidor + Custo_Fabricante

Ithallo Diego disse...

Para mim deu certo desse jeito:
----------------
algoritmo "cust_veiculo_de_fabr"
var custcons, custfabr : real
inicio
escreva ("Insira valor de fábrica do veículo")
leia (custfabr)
custfabr <- custfabr * 1.28
custcons <- custfabr * 1.45
escreva ("O custo do consumidor é: R$", custcons)
fimalgoritmo
-----------------

Dj Zamorak disse...

Galera, nunca vi um carro Usado com valor maior que o de fábrica, foi o que todos esses exemplos falaram!

Segue abaixo a formula certa:
programa
{
funcao inicio()
{
real CF,PD,C,I

escreva ("Informe o custo de fábrica do carro: ")
leia (CF)
PD = 0.28
I = 0.45
C = CF*(PD+I)

escreva ("O valor do automóvel para o consumidor é: R$ ", C)

}
}

Fach1n1 disse...

SEGUE A CORRETA:

programa
{
funcao inicio()
{
limpa()
real CF,PD,C,I
escreva ("Informe o custo de fábrica do carro: ")
leia (CF)

PD = (CF*0.28)
I = (CF*0.45)
C = CF+(PD+I)

escreva ("O valor do automóvel para o consumidor é: R$ ", C)
}
}

Fach1n1 disse...

EXEMPLO:
Informe o custo de fábrica do carro: 10000
O valor do automóvel para o consumidor é: R$ 17300.0
Programa finalizado. Tempo de execução: 2765 milissegundos

Fach1n1 disse...

EXEMPLO:
Informe o custo de fábrica do carro: 10000
O valor do automóvel para o consumidor é: R$ 17300.0
Programa finalizado. Tempo de execução: 2765 milissegundos

Postar um comentário

 
;